Thread (20 messages) flat view 20 messages, 5 authors, 2011-02-18
STALE5672d

[PATCH 0/11] ARM: EXYNOS4: Change ARCH name, ARCH_EXYNOS4 from ARCH_S5PV310

From: Kyungmin Park <hidden>
Date: 2011-02-15 04:39:17
Also in: linux-samsung-soc

On Tue, Feb 15, 2011 at 10:52 AM, Sangbeom Kim [off-list ref] wrote:
Hi,

On Monday, February 14, 2011 8:16 PM, Kyungmin Park wrote:
quoted
quoted
Hi,
I answer your questions in detail.
quoted
On Monday, February 14, 2011 8:16 PM, Kyungmin Park wrote:

Hi,

Wow, fast move, but need to more explanation.
what's the exact meaning of exynos4210?
Exynos4 is prefix and remaining are variants?
Exynos4210 means below.

1st digit means ARM core version. In this case, 4 means Cortex A9.
(If we release cortex A15, it will be Exynos5xxx)
2nd digit means number of core. ?2 mean dual core.
3rd digit means application category(LSI internal category).
4th digit means design rule (generation or shrink version)
Nice, I want these rules.
quoted
quoted
Now you changed all s5pv310 to exynos4. if new exynos4xxx chip are
comes then how to handle this one?
e.g., exynos4220 or later.
it's also conflict with mach-exynos4. do you handle all exynos4 series
at this mach directory?
historically there's no rules of the base RAM address at least samsung
chips.
Yes, we will handle all exynos4 series at mach-exynos4 directory.
In the past, there is no rule.
But now, we are making consistent rules with AP design team.
So, new version of exynos4 series will have same base RAM address.
Okay, no problem with base ram address,

Another one is how do you handle the GPIOs?
Now it's also changed as EXYNOS4_GPXX, I think it's difficult to use
the same banks as exynos4210 has if new chips are introduced.
maybe IRQ also has similar issue.
We already had reviewed your concern before.
S5P6450 and S5P6440 is basically same processor.
But GPIO, IRQ and some peripheral is little different.
We can handle that by checking each processors chipid.

Please check the below patch.
http://www.spinics.net/lists/linux-samsung-soc/msg03530.html
Right, in this patch it used the S5P64XX, S5P6440, and S5P6450 is used.
but EXYNOS patches used the EXYNOS4 prefix instead of EXYNOS4210 at
least at GPIO patch.
maybe you will rename it as EXYNOS4210 and use the EXYNOS4 as
representative prefix.

Anyway it means it will use the cpu_is_exynos4210 or similar style to
detect each cpu. and assign proper data structure
Then I recommend that create the cpu.h header file as other SOC does
and use a common macro if new one comes.

Thank you,
Kyungmin Park
Thanks and regards,
Sangbeom Kim
quoted
Now these patches assumes all exynos4 has same gpios, irqs and so on.

How do you think about it?

Thank you,
Kyungmin Park
quoted
Thanks and regards,
Sangbeom Kim
quoted
Thank you,
Kyungmin Park

On Mon, Feb 14, 2011 at 5:22 PM, Kukjin Kim [off-list ref]
wrote:
quoted
quoted
quoted
This patch set changes to ARCH_EXYNOS4 from ARCH_S5PV310 for
supporting
quoted
quoted
Samsung's
quoted
new brand name EXYNOS. Samsung officially announced about the brand
name
quoted
quoted
of EXYNOS
quoted
at MWC 2011 and The EXYNOS4 integrates a ARM Cortex A9 microporcessor
with several
quoted
other peripherals to support features such as multimedai, storage,
graphics and gaming.
quoted
Especially, the EXYNOS4210 CPU which is one of EXYNOS4 SoC series can
be
quoted
quoted
used in
quoted
products such as Mobile devices.

This patch set consists of the following patches.

[PATCH 01/11] ARM: EXYNOS4: Add EXYNOS4 CPU initialization support
[PATCH 02/11] ARM: EXYNOS4: Update Clock part
[PATCH 03/11] ARM: EXYNOS4: Update IRQ part
[PATCH 04/11] ARM: EXYNOS4: Update Timer part
[PATCH 05/11] ARM: EXYNOS4: Update device support
[PATCH 06/11] ARM: EXYNOS4: Moved board support files
[PATCH 07/11] ARM: EXYNOS4: Update Kconfig and Makefile for the new
ARCH_EXYNOS4
quoted
[PATCH 08/11] ARM: exynos4_defconfig: Add defconfig for EXYNOS4
[PATCH 09/11] mtd: OneNAND: Change dependency of ARCH_EXYNOS4
[PATCH 10/11] ASoC: Change dependency of ARCH_EXYNOS4
[PATCH 11/11] tty: Change dependency of ARCH_EXYNOS4

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel at lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
--
To unsubscribe from this list: send the line "unsubscribe linux-
samsung-
quoted
quoted
soc" in
the body of a message to majordomo at vger.kernel.org
More majordomo info at ?http://vger.kernel.org/majordomo-info.html
--
To unsubscribe from this list: send the line "unsubscribe linux-samsung-
soc" in
quoted
the body of a message to majordomo at vger.kernel.org
More majordomo info at ?http://vger.kernel.org/majordomo-info.html
--
To unsubscribe from this list: send the line "unsubscribe linux-samsung-
soc" in
the body of a message to majordomo at vger.kernel.org
More majordomo info at ?http://vger.kernel.org/majordomo-info.html
--
To unsubscribe from this list: send the line "unsubscribe linux-samsung-soc" in
the body of a message to majordomo at vger.kernel.org
More majordomo info at ?http://vger.kernel.org/majordomo-info.html
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help