On Fri, 2011-02-11 at 13:00 -0800, Steve Muckle wrote:
On 02/11/11 12:58, Daniel Walker wrote:
quoted
On Fri, 2011-02-11 at 12:51 -0800, Steve Muckle wrote:
quoted
On 02/11/11 12:42, Daniel Walker wrote:
quoted
quoted
static struct resource msm_iommu_jpegd_resources[] = {
{
- .start = MSM_IOMMU_JPEGD_PHYS,
- .end = MSM_IOMMU_JPEGD_PHYS + MSM_IOMMU_JPEGD_SIZE - 1,
+ .start = 0x07300000,
+ .end = 0x07300000 + SZ_1M - 1,
Looks worse .. Just put the macros into a static header file for both.
Why bother defining macros for these if they only appear here? I don't
think that adds any value or readability - these addresses are clearly
the physical area for the msm_iommu_jpegd. It just makes it more
annoying to have to look up the values in a separate file if you are
wondering what they are.
So your saying if you look at the number 0x07300000 you instantly know
that this JPEGD?
Yes, because it's the start address for the msm_iommu_jpegd resource.
Yeah I guess that's true .. I still think it's better design not to do
it this way.
Daniel
--
Sent by an consultant of the Qualcomm Innovation Center, Inc.
The Qualcomm Innovation Center, Inc. is a member of the Code Aurora
Forum.