On Wed, Jan 19 2011, Jamie Iles wrote:
On Wed, Jan 19, 2011 at 09:31:55AM -0800, David Brown wrote:
quoted
I'm not sure what would be a better name for the flag, though. The
block is called UARTDM.
Ok, it was mainly out of curiosity. I guess it could be 'use_dma' or
perhaps a comment to explain what DM is but my curiosity is now
satisfied ;-)
I think use_dma would probably be even more confusing, since it isn't
using dma.
It's a flag indicating if the device has the capability of doing dma.
It's really a block version indicator, except that the blocks weren't
given different versions, but instead given a name based on the DMA.
I wonder if is_dma_capable would be better.
David
--
Sent by an employee of the Qualcomm Innovation Center, Inc.
The Qualcomm Innovation Center, Inc. is a member of the Code Aurora Forum.