Thread (16 messages) 16 messages, 2 authors, 2021-07-29

Re: [PATCH v2 5/7] kallsyms: Rename is_kernel() and is_kernel_text()

From: Steven Rostedt <rostedt@goodmis.org>
Date: 2021-07-28 15:28:41
Also in: bpf, linuxppc-dev, lkml

On Wed, 28 Jul 2021 16:13:18 +0800
Kefeng Wang [off-list ref] wrote:
The is_kernel[_text]() function check the address whether or not
in kernel[_text] ranges, also they will check the address whether
or not in gate area, so use better name.
Do you know what a gate area is?

Because I believe gate area is kernel text, so the rename just makes it
redundant and more confusing.

-- Steve
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help