Thread (18 messages) flat view 18 messages, 6 authors, 2021-07-07

Re: [PATCH 3/9] sections: Move and rename core_kernel_data() to is_kernel_data()

From: Steven Rostedt <rostedt@goodmis.org>
Date: 2021-06-29 01:05:45
Also in: lkml

On Sat, 26 Jun 2021 15:34:33 +0800
Kefeng Wang [off-list ref] wrote:
Move core_kernel_data() into sections.h and rename it to
is_kernel_data(), also make it return bool value, then
update all the callers.
Removing the "core" part of "core_kernel_data()" is misleading. As
modules can have kernel data, but this will return false on module data
(as it should). This is similar to core_kernel_text() which this series
doesn't seem to touch.

I'd like to keep the "core" in the name which makes it obvious this is
not about module data, and if someone were to make it about module
data, it will break ftrace synchronization.

-- Steve
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help