Re: [PATCH 3/4] watchdog: Split up config options
From: Don Zickus <hidden>
Date: 2017-06-12 20:42:01
Also in:
lkml
On Mon, Jun 12, 2017 at 06:07:39PM +1000, Nicholas Piggin wrote:
quoted
quoted
This would probably be the right direction to go in, but it will take slightly more I think. We first need to remove HAVE_NMI_WATCHDOG from meaning that an arch has its own watchdog and does not want any HLD stuff. I think with arch_touch_nmi_watchdog(), we can probably get there. While transitioning, we could add a new option instead, HAVE_ARCH_HARDLOCKUP_DETECTOR I think HAVE_PERF_EVENTS_NMI is sufficient to imply it will use the PERF HLD. Possibly you could just change the name to be a bit more regular, HAVE_PERF_NMI_HARDLOCKUP_DETECTORActually, I don't think I can just rename it as it has a specific use to let OPROFILE know the perf events are being NMI triggered as opposed to IRQ triggered. Though I like the direction you are going. Then arches either have one or the other. Or in the ppc case it is dependent on what ppc platform is being used.Okay, glad we're on the same page conceptually :)quoted
Then the HARDLOCKUP_DETECTOR needs one or the other to work correctly with the arch/<arch>/Kconfig explicitly stating which one to use?Yeah I guess the arch would advertise it has the PERF_HLD or ARCH_HLD if it provides its own. HARDLOCKUP_DETECTOR option would then depend on one of the two being defined. I could try redoing the series with those changes to Kconfig and see how it looks?
Yeah, if you wouldn't mind. Sorry for dragging this out, but I feel like we are getting close to have this defined properly which would allow us to split the code up correctly in the future. Cheers, Don