Thread (103 messages) flat view 103 messages, 14 authors, 2025-10-10

Re: [PATCH RESEND 28/62] init: alpha, arc, arm, arm64, csky, m68k, microblaze, mips, nios2, openrisc, parisc, powerpc, s390, sh, sparc, um, x86, xtensa: rename initrd_{start,end} to virt_external_initramfs_{start,end}

From: Borislav Petkov <bp@alien8.de>
Date: 2025-09-13 05:49:47
Also in: linux-acpi, linux-alpha, linux-arch, linux-block, linux-devicetree, linux-doc, linux-efi, linux-ext4, linux-fsdevel, linux-m68k, linux-mips, linux-patches, linux-riscv, linux-s390, linux-sh, linux-um, linuxppc-dev, lkml, loongarch, sparclinux

On Sat, Sep 13, 2025 at 12:38:07AM +0000, Askar Safin wrote:
Rename initrd_start to virt_external_initramfs_start and
initrd_end to virt_external_initramfs_end.
"virt" as in "virtualization"?

That's not confusing at all... :-\

And "external" means what?
They refer to initramfs, not to initrd
Why not simply initramfs_{start,end} if they belong to it?

-- 
Regards/Gruss,
    Boris.

https://people.kernel.org/tglx/notes-about-netiquette
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help