On Fri, 2025-09-05 at 16:43 +0100, Mark Brown wrote:
On Fri, Sep 05, 2025 at 05:21:59PM +0200, Christian Brauner wrote:
quoted
On Tue, Sep 02, 2025 at 11:21:48AM +0100, Mark Brown wrote:
quoted
quoted
+ .shadow_stack_token = args.shadow_stack_token,
quoted
I'm not sure why this has to be named "shadow_stack_token" I think
that's just confusing and we should just call it "shadow_stack" and be
done with it. It's also a bit long of a field name imho.
I'm not hugely attached to the name, if you want to rename that's
perfectly fine by me. My thinking was that there's a potential
confusion with it being a pointer to the base of the shadow stack by
comparison with the existing "stack" but I do agree that the resulting
name is quite long and if someone does actually get confused they should
discover the problem fairly rapidly in testing. ss_token would shorter
but the abbreviation is less clear, whatever name you prefer is fine by
me.
Yea the token point here is kind of important. That said, we could probably make
up for it with documentation.