On Mon 18-10-21 21:00:06, Gabriel Krisman Bertazi wrote:
fanotify_error_event would duplicate this sequence of declarations that
already exist elsewhere with a slight different size. Create a helper
macro to avoid code duplication.
Suggested-by: Jan Kara <jack@suse.cz>
Signed-off-by: Gabriel Krisman Bertazi <redacted>
---
Among the suggestions, I think this is simpler because it avoids
deep nesting the variable-sized attribute, which would have been hidden
inside fee->ffe->object_fh.buf.
One nit from me as well :)
+#define FANOTIFY_INLINE_FH(size) \
+struct { \
+ struct fanotify_fh object_fh; \
+ /* Space for object_fh.buf[] - access with fanotify_fh_buf() */ \
+ unsigned char _inline_fh_buf[(size)]; \
+}
+
Can the macro perhaps take the name of the fanotify_fh member it creates?
Like:
#define FANOTIFY_INLINE_FH(name, size)
Harcoding _inline_fh_buf is fine since it isn't ever used directly but
hardcoding object_fh looks ugly to me. With that improved feel free to add:
Reviewed-by: Jan Kara <jack@suse.cz>
Honza
--
Jan Kara [off-list ref]
SUSE Labs, CR