On Sat, Nov 28, 2020 at 04:54:50PM -0600, Serge Hallyn wrote:
On Sat, Nov 28, 2020 at 10:34:49PM +0100, Christian Brauner wrote:
quoted
Hey everyone,
Hey Christian,
a general request. Argue with me if it seems misguided.
When looking at a patch or a small hunk of code, these days, if a variable
called 'ns' or 'user_ns' is seen passed to a function, it can be easy to
assume which user_ns it is based on what you think would make sense, but if
your assumption is wrong, your patch review will be wrong.
Can we stick to a convention where we have maybe
subj_userns - the userns of the task seeking some action
obj_userns - the userns of the thing being acted on - task, superblock,...
mnt_userns - the userns of a mountpoint through which an object is seen
You're replacing a lot of such callers and callsites in this patchset, so
this would be a great time to start doing that.
Hey Serge,
this makes a lot of sense. I'll convert all accesses to the vfsmount's
userns we're introducing in this series to to mnt_userns at least.
Christian