On Thu, Sep 10, 2020 at 04:18:28PM +0100, Al Viro wrote:
On Thu, Sep 10, 2020 at 10:23:37AM -0400, Rich Felker wrote:
quoted
It was determined (see glibc issue #14578 and commit a492b1e5ef) that,
on some filesystems, performing chmod on the link itself produces a
change in the inode's access mode, but returns an EOPNOTSUPP error.
Which filesystem types are those?
It's been a long time and I don't know if the details were recorded.
It was reported for xfs but I believe we later found it happening for
others. See:
https://sourceware.org/bugzilla/show_bug.cgi?id=14578#c17
https://sourceware.org/legacy-ml/libc-alpha/2020-02/msg00467.html
and especially:
https://sourceware.org/legacy-ml/libc-alpha/2020-02/msg00518.html
where Christoph seems to have endorsed the approach in my patch. I'm
fine with doing it differently if you'd prefer, though.
Rich