Thread (55 messages) 55 messages, 8 authors, 2022-03-02

Re: [PATCH v4 1/6] fs: introduce FMODE_ZONE_APPEND and IOCB_ZONE_APPEND

From: Christoph Hellwig <hch@infradead.org>
Date: 2020-07-28 07:27:08
Also in: io-uring, linux-block, linux-fsdevel, lkml

On Tue, Jul 28, 2020 at 02:49:59AM +0100, Matthew Wilcox wrote:
On Sun, Jul 26, 2020 at 04:18:10PM +0100, Christoph Hellwig wrote:
quoted
Zone append is a protocol context that ha not business showing up
in a file system interface.  The right interface is a generic way
to report the written offset for an append write for any kind of file.
So we should pick a better name like FMODE_REPORT_APPEND_OFFSET
(not that I particularly like that name, but it is the best I could
quickly come up with).
Is it necessarily *append*?  There were a spate of papers about ten
years ago for APIs that were "write anywhere and I'll tell you where it
ended up".  So FMODE_ANONYMOUS_WRITE perhaps?
But that really is not the semantics I had in mind - both the semantics
for the proposed Linux file API and the NVMe Zone Append command say
write exactly at the write pointer (NVMe) or end of the file (file API).
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help