On 12/11/19 9:17 AM, Mathieu Desnoyers wrote:
glibc 2.30 introduces gettid() in public headers, which clashes with
the internal static definition within rseq selftests.
Rename gettid() to rseq_gettid() to eliminate this symbol name clash.
Reported-by: Tommi T. Rantala <redacted>
Signed-off-by: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
Cc: Shuah Khan <skhan@linuxfoundation.org>
Cc: Tommi T. Rantala <redacted>
Cc: Thomas Gleixner <redacted>
Cc: Peter Zijlstra (Intel) <peterz@infradead.org>
Cc: "Paul E. McKenney" <redacted>
Cc: Boqun Feng <redacted>
Cc: "H . Peter Anvin" <hpa@zytor.com>
Cc: Paul Turner <redacted>
Cc: Dmitry Vyukov <dvyukov@google.com>
Cc: <redacted> # v4.18+
---
tools/testing/selftests/rseq/param_test.c | 18 ++++++++++--------
I am pulling this patch in for Linux 5.5-rc4.
Let me know if you have any objections.
thanks,
-- Shuah