Thread (18 messages) flat view 18 messages, 2 authors, 2019-10-18

Re: [PATCH v2 1/5] pidfd: verify task is alive when printing fdinfo

From: Oleg Nesterov <oleg@redhat.com>
Date: 2019-10-17 08:54:24
Also in: linux-kselftest, lkml

On 10/16, Christian Brauner wrote:
On Wed, Oct 16, 2019 at 06:24:09PM +0200, Oleg Nesterov wrote:
quoted
And why task_ if it accepts pid+pid_type? May be pid_has_task() or
something like this...
Given what I said above that might be a decent name.
quoted
OK, since I can't suggest a better name I won't really argue. Feel free
to add my reviewed-by to this series.
No, naming is important. Thanks for being picky about that too and I'll
happily resend. :)
Thanks ;) May be pid_in_use() ? Up to you, anything which starts with pid_
looks better to me than task_alive().

Oleg.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help