Thread (19 messages) 19 messages, 7 authors, 2018-05-29

Re: [RFC PATCH 0/5] kmalloc-reclaimable caches

From: Johannes Weiner <hannes@cmpxchg.org>
Date: 2018-05-24 15:30:30
Also in: linux-mm, lkml

On Thu, May 24, 2018 at 01:00:06PM +0200, Vlastimil Babka wrote:
- the vmstat/meminfo counter name is rather general and might suggest it also
  includes reclaimable page caches, which it doesn't

Suggestions welcome for all three points. For the last one, we might also keep
the counter separate from nr_slab_reclaimable, not superset. I did a superset
as IIRC somebody suggested that in the older threads or at LSF.
Yeah, the "reclaimable" name is too generic. How about KReclaimable?

The counter being a superset sounds good to me. We use this info for
both load balancing and manual debugging. For load balancing code it's
nice not having to worry about finding all the counters that hold
reclaimable memory depending on kernel version; it's always simply
user cache + user anon + kernel reclaimable. And for debugging, we can
always add more specific subset counters later on if we need them.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help