On Thu, Mar 01, 2018 at 01:15:21PM -0800, Matthew Wilcox wrote:
From: Matthew Wilcox <redacted>
We're already using a union of many fields here, so stop abusing the
_map_count and make page_type its own field. That implies renaming some
s/_map_count/_mapcount/
and in subject.
of the machinery that creates PageBuddy, PageBalloon and PageKmemcg;
bring back the PG_buddy, PG_balloon and PG_kmemcg names.
As suggested by Kirill, make page_type a bitmask. Because it starts out
life as -1 (thanks to sharing the storage with _map_count), setting a
page flag means clearing the appropriate bit. This gives us space for
probably twenty or so extra bits (depending how paranoid we want to be
about _mapcount underflow).
Signed-off-by: Matthew Wilcox <redacted>
Acked-by: Kirill A. Shutemov <redacted>
--
Kirill A. Shutemov