Thread (44 messages) 44 messages, 11 authors, 2017-12-08

Re: [PATCH 0/2] mm: introduce MAP_FIXED_SAFE

From: Michal Hocko <hidden>
Date: 2017-12-06 09:08:18
Also in: linux-arch, linux-mm, lkml

On Wed 06-12-17 08:33:37, Rasmus Villemoes wrote:
On 2017-12-06 05:50, Michael Ellerman wrote:
quoted
Michal Hocko [off-list ref] writes:
quoted
On Wed 29-11-17 14:25:36, Kees Cook wrote:
It is safe in a sense it doesn't perform any address space dangerous
operations. mmap is _inherently_ about the address space so the context
should be kind of clear.
So now you have to define what "dangerous" means.
quoted
quoted
MAP_FIXED_UNIQUE
MAP_FIXED_ONCE
MAP_FIXED_FRESH
Well, I can open a poll for the best name, but none of those you are
proposing sound much better to me. Yeah, naming sucks...
I also don't like the _SAFE name - MAP_FIXED in itself isn't unsafe [1],
but I do agree that having a way to avoid clobbering (parts of) an
existing mapping is quite useful. Since we're bikeshedding names, how
about MAP_FIXED_EXCL, in analogy with the O_ flag.
I really give up on the name discussion. I will take whatever the
majority comes up with. I just do not want this (useful) funtionality
get bikeched to death.
-- 
Michal Hocko
SUSE Labs
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help