Thread (23 messages) flat view 23 messages, 7 authors, 2017-07-19

Re: [PATCH v10 2/3] arm/syscalls: Check address limit on user-mode return

From: Will Deacon <hidden>
Date: 2017-06-21 09:08:16
Also in: linux-arm-kernel, lkml

On Tue, Jun 20, 2017 at 01:31:14PM -0700, Thomas Garnier wrote:
On Tue, Jun 20, 2017 at 1:18 PM, Kees Cook [off-list ref] wrote:
quoted
On Wed, Jun 14, 2017 at 6:12 PM, Thomas Garnier [off-list ref] wrote:
quoted
diff --git a/arch/arm/kernel/entry-common.S b/arch/arm/kernel/entry-common.S
index eb5cd77bf1d8..e33c32d56193 100644
--- a/arch/arm/kernel/entry-common.S
+++ b/arch/arm/kernel/entry-common.S
@@ -41,7 +41,9 @@ ret_fast_syscall:
  UNWIND(.cantunwind    )
        disable_irq_notrace                     @ disable interrupts
        ldr     r1, [tsk, #TI_FLAGS]            @ re-check for syscall tracing
-       tst     r1, #_TIF_SYSCALL_WORK | _TIF_WORK_MASK
+       tst     r1, #_TIF_SYSCALL_WORK
+       bne     fast_work_pending
+       tst     r1, #_TIF_WORK_MASK
(IIUC) MOV32 is 2 cycles (MOVW, MOVT), and each TST above is 1 cycle
and each BNE is 1 cycle (when not taken). So:

mov32 r2, #_TIF_SYSCALL_WORK | _TIF_WORK_MASK
tst r1, r2
bne fast_work_pending

is 4 cycles and tst, bne, tst, bne is also 4 cycles. Would mov32 be
more readable (since it keeps the flags together)?
I guess it would be more readable. Any opinion from the arm folks?
The mov32 sequence is probably better, but statically attributing cycles
on a per instruction basis is pretty futile on modern CPUs.

Will
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help