Thread (2 messages) 2 messages, 2 authors, 2016-02-27

Re: [PATCH 2/7] vfs: vfs: Define new syscalls preadv2,pwritev2

From: Christoph Hellwig <hch@lst.de>
Date: 2016-02-27 08:58:23
Also in: linux-fsdevel

On Fri, Feb 26, 2016 at 04:51:24PM -0500, Jeff Moyer wrote:
Christoph Hellwig [off-list ref] writes:
quoted
From: Milosz Tanski <redacted>

New syscalls that take an flag argument. This change does not add any
specific flags.
So, it looks like file systems that don't implement read_iter/write_iter
won't get the flags argument passed along.  I don't think that's a big
deal, as such file systems seem to be in-memory file systems, but I
think it warrants mention in the changelog.
Ok.
Also, I think you added a stray newline below:
quoted
+static long do_compat_pwritev64(unsigned long fd,
 				   const struct compat_iovec __user *vec,
-				   unsigned long vlen, loff_t pos)
+				   unsigned long vlen, loff_t pos, int flags)
 {
 	struct fd f;
 	ssize_t ret;
 
 	if (pos < 0)
 		return -EINVAL;
+
 	f = fdget(fd);
 	if (!f.file)
 		return -EBADF;
 	ret = -ESPIPE;
 	if (f.file->f_mode & FMODE_PWRITE)
-		ret = compat_writev(f.file, vec, vlen, &pos);
+		ret = compat_writev(f.file, vec, vlen, &pos, flags);
 	fdput(f);
 	return ret;
 }
Yeah, no real need to add it, although the new version is defintively
more readable.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help