Thread (19 messages) 19 messages, 3 authors, 2015-10-01

Re: [PATCH v3 4/5] kcmp: add KCMP_FILE_PRIVATE_DATA

From: Andy Lutomirski <hidden>
Date: 2015-09-30 18:47:32
Also in: lkml, netdev

On Wed, Sep 30, 2015 at 11:41 AM, Tycho Andersen
[off-list ref] wrote:
On Wed, Sep 30, 2015 at 11:25:41AM -0700, Andy Lutomirski wrote:
quoted
On Wed, Sep 30, 2015 at 11:13 AM, Tycho Andersen
[off-list ref] wrote:
quoted
This command allows comparing the underling private data of two fds. This
is useful e.g. to find out if a seccomp filter is inherited, since struct
seccomp_filter are unique across tasks and are the private_data seccomp
fds.
This is very implementation-specific and may have nasty ABI
consequences far outside seccomp.  Let's do something specific to
seccomp and/or eBPF.
We could change the name to a less generic KCMP_SECCOMP_FD or
something, but without some sort of GUID on each struct
seccomp_filter, the implementation would be effectively the same as it
is today. Is that enough, or do we need a GUID?
I don't care about the GUID.  I think we should name it
KCMP_SECCOMP_FD and make it only work on seccomp fds.

Alternatively, we could figure out why KCMP_FILE doesn't do the trick
and consider fixing it.  IMO it's really too bad that struct file is
so heavyweight that we can't really just embed one in all kinds of
structures.


--Andy
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help