@@ -284,11 +287,31 @@ static void via_pram_command(int commandstaticunsignedcharvia_pram_read_byte(intoffset){-return0;+unsignedchartemp;+intaddr=((offset&0xE0)<<3)|((offset&0x1F)<<2);++/* Use RTC command 0x38 for XPRAM access, as per MESS source code */+via_pram_command(addr|0x3800|0x8001,&temp);++returntemp;}staticvoidvia_pram_write_byte(unsignedchardata,intoffset){+unsignedchartemp;+intaddr=((offset&0xE0)<<3)|((offset&0x1F)<<2);++/* Clear the write protect bit */+temp=0x55;+via_pram_command(0x34|0x01,&temp);++/* Write the byte to XPRAM */+temp=data;+via_pram_command(0x3800|0x0001|addr,&temp);++/* Set the write protect bit */+temp=0xD5;+via_pram_command(0x34|0x01,&temp);}/*
Gr{oetje,eeting}s,
Geert
--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert-Td1EMuHUCqxL1ZNQvxDV9g@public.gmane.org
In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds
This is just marshalling the offset argument. I don't know how to rewrite
that code more clearly. I'm open to suggestions. I don't know of any
documentation that gives names or meanings to the different bit ranges. I
infered the format from the MESS source code,
https://github.com/mamedev/mame/blob/master/src/mess/machine/macrtc.c
What I found in the MESS source code looks like the result of reverse
engineering. Hence the RTC code in this patch also looks like a reverse
engineered driver.
quoted
+
+ /* Use RTC command 0x38 for XPRAM access, as per MESS source code */
+ via_pram_command(addr | 0x3800 | 0x8001, &temp);
It seems 0x38 is already documented in <linux/pmu.h> (see below), or not
(it's shifted left by 8 bits?)?
No, this is a RTC command not a PMU command. This RTC device is an Apple
custom IC that is publicly undocumented. OTOH, the PMU device is well
documented, since Apple publicly released PMU driver source code in
MkLinux and later in XNU. That's why I've been able to provide #defines
for the PMU commands but not the RTC commands.
quoted
+
+ return temp;
}
static void via_pram_write_byte(unsigned char data, int offset)
{
+ unsigned char temp;
+ int addr = ((offset & 0xE0) << 3) | ((offset & 0x1F) << 2);
+
+ /* Clear the write protect bit */
+ temp = 0x55;
+ via_pram_command(0x34 | 0x01, &temp);
+
+ /* Write the byte to XPRAM */
+ temp = data;
+ via_pram_command(0x3800 | 0x0001 | addr, &temp);
+
+ /* Set the write protect bit */
+ temp = 0xD5;
+ via_pram_command(0x34 | 0x01, &temp);
More magic values...
When I have reliable documentation I always define macros. So I agree that
"command" bytes like 0x34 and 0x3800 should have names but what are the
correct names? Are we constructing an opcode containing RTC register file
addresses or are we issuing read/write accesses to chip registers?
In my experience with undocumented 68k Mac hardware and its Linux port,
codified guesswork is worse than no documentation at all. The only useful
RTC documentation I've ever come across is this:
http://mac.linux-m68k.org/devel/plushw.php
It tells us that the two least significant bits bits must equal 0b01. What
would you call that macro? It also tells us that the most significant bit,
0x80, means "read access" but it only mentions early RTC chips and so it
does not cover two byte opcodes. Should I have used 0x8080 here?
Whatever your opinion of reverse engineered drivers, the changes in this
patch are consistent with the rest of the file. E.g. via_read_time() and
via_write_time(). If/when we have the chip data needed to correctly define
macros for 0x01, 0x0001, 0x80, 0x8000 or 0x8080, I think they should be
applied across the entire file, and in a different patch. Inconsistent use
of such macros would be undesirable IMHO.
This document appears to be Inside Macintosh vol. III ch. 2. It describes
the early RTC chip that lacks two-byte operations and XPRAM, and pre-dates
all Mac hardware supported in mainline Linux. But it does offer some
useful data, though not enough to answer all of your criticisms (as I
said).
[...] I think they should be applied across the entire file, and in a
different patch. Inconsistent use of such macros would be undesirable
IMHO.
So, unless you have other ideas, I will revise this patch and insert an
earlier patch to address existing code, and codify what little reliable
chip data we have.
--
This document appears to be Inside Macintosh vol. III ch. 2. It describes
the early RTC chip that lacks two-byte operations and XPRAM, and pre-dates
all Mac hardware supported in mainline Linux. But it does offer some
useful data, though not enough to answer all of your criticisms (as I
said).
I understand.
quoted
[...] I think they should be applied across the entire file, and in a
different patch. Inconsistent use of such macros would be undesirable
IMHO.
So, unless you have other ideas, I will revise this patch and insert an
earlier patch to address existing code, and codify what little reliable
chip data we have.
Thanks!
Gr{oetje,eeting}s,
Geert
--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert-Td1EMuHUCqxL1ZNQvxDV9g@public.gmane.org
In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds