On Fri, Mar 27, 2015 at 10:04:11AM -0700, Andrew Morton wrote:
mm... I don't think we should be adding placeholders to the kernel API
to support code which hasn't been written, tested, reviewed, merged,
etc. It's possible none of this will ever happen and we end up with a
syscall nobody needs or uses. Plus it's always possible that during
this development we decide the pwrite2() interface needs alteration but
it's too late.
What would be the downside of deferring pwrite2() until it's all
implemented?
It _is_ implemented. I just decided to submit it separately as Miklos
already has to deal with enough bikeshedding for his feature that I
don't want to put the burden of dealing with the BS for the one I wrote
on him.
--
To unsubscribe, send a message with 'unsubscribe linux-aio' in
the body to majordomo@kvack.org. For more info on Linux AIO,
see: http://www.kvack.org/aio/
Don't email: <a href=mailto:"aart@kvack.org">aart@kvack.org</a>