Thread (83 messages) 83 messages, 14 authors, 2015-02-08

Re: [PATCH v3 00/13] Add kdbus implementation

From: Daniel Mack <hidden>
Date: 2015-01-17 00:33:28
Also in: lkml

Hi Josh,

On 01/16/2015 11:18 PM, Greg Kroah-Hartman wrote:
On Fri, Jan 16, 2015 at 05:07:25PM -0500, Josh Boyer wrote:
quoted
The code.google.com tree has commits
from 2 days ago, but it still calls d_materialise_unique in fs.c
whereas the patchset you've posted uses the correct d_splice_alias.
So the code.google.com tree doesn't actually compile against 3.19-rcX.

I'm confused where we're supposed to track things now.
The code.google.com repository is where we do all the development, and
the code is made to build external kernel modules for 3.18. The patches
sent in this series are meant for 3.19 and 3.20 kernels, and while they
are based on the exact same sources, the patches differ in the following
minor details:

 * Code is moved to appropriate locations, such as ipc/kdbus,
   include/uapi, tools/testing/selftests/kdbus/, Documentation/ etc.

 * Include file location amendments, "kdbus.h" vs. <uapi/linux/kdbus.h>

 * Added iov_iter_kvec() usage, as that's a new API in v3.19

 * The file system magic number is moved to include/uapi/linux/magic.h

 * d_materialise_unique() is renamed to d_splice_alias() to catch up
   with changes in 3.19


The commit this patch set is based on is tagged as "lkml-v3" in the
upstream repository now.


Thanks,
Daniel
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help