On Tue, Nov 25, 2014 at 04:44:53PM -0500, Stefan Berger wrote:
On 11/11/2014 08:45 AM, Jarkko Sakkinen wrote:
quoted
Rename chip->dev to chip->pdev to make it explicit that this not the
character device but actually represents the platform device.
Signed-off-by: Jarkko Sakkinen <jarkko.sakkinen-VuQAYsv1563Yd54FQh9/CA@public.gmane.org>
quoted
diff --git a/drivers/char/tpm/tpm.h b/drivers/char/tpm/tpm.h
index 69f4003..b3a7c76 100644
--- a/drivers/char/tpm/tpm.h
+++ b/drivers/char/tpm/tpm.h
@@ -98,7 +98,7 @@ struct tpm_vendor_specific {
#define TPM_PPI_VERSION_LEN 3
struct tpm_chip {
- struct device *dev; /* Device stuff */
+ struct device *pdev; /* Device stuff */
const struct tpm_class_ops *ops;
int dev_num; /* /dev/tpm# */
So this is the core requiring the renamings. I assume you got them all and
none were hidden in #if's or so.
Yup, I basically did :argdo %s/chip->dev/chip->pdev/g for *.[ch].
Reviewed-by: Stefan Berger <redacted>
/Jarkko