Re: preadv2/pwritev2 rename
From: H. Peter Anvin <hidden>
Date: 2014-10-21 20:07:39
On 10/20/2014 11:42 PM, Michael Kerrisk (man-pages) wrote:
Hello Milosz, On Mon, Oct 20, 2014 at 11:52 PM, Milosz Tanski [off-list ref] wrote:quoted
Christoph and/or Jeff, I updated the patch for 3.18-rc1 and I'm going to resend it as non-RFC as I didn't get comments last time. I only have one stupid question... I'm going to rename the calls to preadv6 and pwritev6 (so it's more like the other syscalls: dup3, accept4, eventfd2) but I'm not sure if i should call it preadv5 or pwritev6 since the offset argument is split into two different arguments (upper and lower part).It's points like this that show exactly why naming system calls after the number of their arguments is a very bad idea[1]. Please don't do it. pwritev2() and preadv2() are not pretty either, but are marginally better. pwritev_fl() and preadv_fl() (or simialr) might also be okay, I guess.
The splitting of the argument is a calling convention thing (and a rather stupid one at that... we shouldn't do these kinds of things manually.) As such, it is not visible to the user and should not be counted. -hpa