Re: [PATCH RFC v2 net-next 02/16] bpf: update MAINTAINERS entry
From: Kees Cook <hidden>
Date: 2014-07-23 18:39:24
Also in:
lkml, netdev
On Wed, Jul 23, 2014 at 10:48 AM, Alexei Starovoitov [off-list ref] wrote:
On Wed, Jul 23, 2014 at 10:37 AM, Kees Cook [off-list ref] wrote:quoted
On Thu, Jul 17, 2014 at 9:19 PM, Alexei Starovoitov [off-list ref] wrote:quoted
Signed-off-by: Alexei Starovoitov <ast-uqk4Ao+rVK5Wk0Htik3J/w@public.gmane.org> --- MAINTAINERS | 7 +++++++ 1 file changed, 7 insertions(+)diff --git a/MAINTAINERS b/MAINTAINERS index ae8cd00215b2..32e24ff46da3 100644 --- a/MAINTAINERS +++ b/MAINTAINERS@@ -1912,6 +1912,13 @@ S: Supported F: drivers/net/bonding/ F: include/uapi/linux/if_bonding.h +BPF (Safe dynamic programs and tools)bikeshed: I feel like this shouldn't be an acronym. Maybe instead: BERKELEY PACKET FILTER (BPF: Safe dynamic programs and tools)pile on :) I think eBPF is no longer acronym. 'e' stands for 'extended', but BPF is no longer 'packet filter' only and definitely not 'berkeley'. So I'd rather keep BPF as a magic abbreviation without spelling it out, since full name is historic and no longer meaningful. I've considered coming up with brand new abbreviation and full name for this instruction set, but none looked good and all lose in comparison to 'eBPF' name, which is concise and carries enough historical references to explain the idea behind new ISA.
Yeah, that's a fair point. No sense in using "BEE PEE EFF" :) -Kees -- Kees Cook Chrome OS Security