On Mon, Jun 16, 2014 at 04:36:04AM +0200, Andi Kleen wrote:
At least versioning is always useful to have, just to have
another tool for compatibility if changes are needed.
I disagree. Just like syscalls, vdso functions with new APIs/ABIs
should have new names. For example if a version of clock_gettime for a
new userspace with 64-bit time_t is added, it should be called
clock_gettime64 (with a corresponding __NR_clock_gettime64), not
offered as a versioned symbol over top of the old one. The versioned
symbol approach is a lot more confusing and as far as I can tell
offers no benefits.
Rich