Thread (5 messages) 5 messages, 4 authors, 2012-11-06

Re: [RFC/PATCH] epoll: replace EPOLL_CTL_DISABLE with EPOLL_CTL_POKE

From: Eric Wong <hidden>
Date: 2012-11-06 21:58:54
Also in: linux-fsdevel, lkml

Christof Meerwald [off-list ref] wrote:
On Fri, 2 Nov 2012 04:13:12 +0000, Eric Wong wrote:
[...]
quoted
EPOLL_CTL_POKE may be used to force an item into the epoll
ready list.  Instead of disabling an item asynchronously
via EPOLL_CTL_DISABLE, this forces the threads calling
epoll_wait() to handle the item in its normal loop.
That was my initial suggestion as well - see
https://lkml.org/lkml/2012/6/19/358
Thanks, missed that the first time around.  Perhaps TRIGGER is a
better name than POKE :x

I'm hoping Paton has a chance to look at my implementation and
comment on it.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help