Re: [RFC v17][PATCH 10/60] c/r: make file_pos_read/write() public
From: KAMEZAWA Hiroyuki <hidden>
Date: 2009-07-23 02:35:20
Also in:
linux-mm, lkml
From: KAMEZAWA Hiroyuki <hidden>
Date: 2009-07-23 02:35:20
Also in:
linux-mm, lkml
a nitpick. On Wed, 22 Jul 2009 05:59:32 -0400 Oren Laadan [off-list ref] wrote:
These two are used in the next patch when calling vfs_read/write()
+static inline loff_t file_pos_read(struct file *file)
+{
+ return file->f_pos;
+}
+
+static inline void file_pos_write(struct file *file, loff_t pos)
+{
+ file->f_pos = pos;
+}
+I'm not sure but how about renaming this to file_pos() set_file_pos() at moving this to global include file ? Thanks, -Kame -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@kvack.org. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>