On Wed, Jul 6, 2016 at 6:47 PM, Neil Armstrong [off-list ref] wrote:
2016-07-04 17:38 GMT+02:00 Jassi Brar [off-list ref]:
quoted
On Tue, Jun 21, 2016 at 3:32 PM, Neil Armstrong [off-list ref] wrote:
quoted
Add Amlogic Meson SoCs Message-Handling-Unit as mailbox controller
with 2 independent channels/links to communicate with a remote processor.
Signed-off-by: Neil Armstrong <redacted>
---
drivers/mailbox/Makefile | 2 +
drivers/mailbox/meson_mhu.c | 199 ++++++++++++++++++++++++++++++++++++++++++++
Can we call it pdev_mhu.c or similar so that some other platform using
the MHU as a platform_device wouldn't have to embarrassingly call it
'Meson's MHU'? And also the replace meson with that prefix in the
code.
Yes, it may deserve a more generic naming, but pdev_mhu is not good
looking at all !
What about platform_mhu ?
OK