On Mon, Jun 07, 2021 at 12:31:55PM -0500, Mario Limonciello wrote:
+/**
+ * acpi_storage_d3 - Check if a storage device should use D3.
+ * @dev: Device to check
+ *
+ * Returns %true if @dev should be put into D3 when the ->suspend method is
+ * called, else %false. The name of this function is somewhat misleading
+ * as it has nothing to do with storage except for the name of the ACPI
+ * property. On some platforms resume will not work if this hint is ignored.
+ *
+ */
I still do not like this comment. There is nothing about only using this
for storage devices. It is specific to a PCIe slot, and if I plug
something that is not a storage device into it the same restrictions
still apply.
Also no need for the empty-ish line at the end.