On Fri, Jan 27, 2017 at 01:30:15PM +0000, Dan O'Donovan wrote:
+ if (acpi_of_modalias(adev, spi->modalias, sizeof(spi->modalias)))
+ strlcpy(spi->modalias, acpi_device_hid(adev),
+ sizeof(spi->modalias));
I can't help but think that this would be simpler to use if the
interface were something like acpi_set_modalias() and it did the
fallback to the ACPI HID internally. It'd both avoid a small amount of
code duplication and make the code read a bit more naturally - I have to
think to realise that this means "if there isn't an OF name use the
HID" since it looks like a boolean function. Then again just putting a
!= 0 in the test would have the same effect probably.