Re: [PATCH 2/2]: acpica/nfit: Rename not-armed bit definition
From: Toshi Kani <hidden>
Date: 2015-08-26 23:32:09
Also in:
lkml, nvdimm
On Thu, 2015-08-27 at 01:16 +0200, Rafael J. Wysocki wrote:
On Wed, Aug 26, 2015 at 11:12 PM, Toshi Kani [off-list ref] wrote:quoted
On Wed, 2015-08-26 at 10:16 -0700, Dan Williams wrote:quoted
On Wed, Aug 26, 2015 at 9:20 AM, Toshi Kani [off-list ref] wrote:quoted
ACPI 6.0 NFIT Memory Device State Flags in Table 5-129 defines bit 3 as follows. Bit [3] set to 1 to indicate that the Memory Device is observed to be not armed prior to OSPM hand off. A Memory Device is considered armed if it is able to accept persistent writes. This bit is currently defined as ACPI_NFIT_MEM_ARMED, which can be confusing as if the Memory Device is armed when this bit is set. Change the name to ACPI_NFIT_MEM_NOT_ARMED per the spec. Signed-off-by: Toshi Kani <redacted> Cc: Dan Williams <redacted> Cc: Bob Moore <redacted> Cc: Rafael J. Wysocki <redacted> --- drivers/acpi/nfit.c | 6 +++--- drivers/acpi/nfit.h | 2 +- include/acpi/actbl1.h | 2 +-This file "include/acpi/actbl1.h" is owned by the ACPICA project so any changes need to come through them. But that said, I'm not sure we need friendly names at this level.I think the name is misleading, but I agree with the process and this patch2 can be dropped. It'd be nice if the ACPICA project can pick it up later when they have a chance, though.A good way to cause that to happen would be to send a patch to the ACPICA development list + maintainers as per MAINTAINERS.
Oh, I see. I did run get_maintainer.pl for this patch, but devel@acpica.org did not come out in output... So, I did not realize this email list. Thanks for the suggestion! -Toshi