Thread (119 messages) 119 messages, 9 authors, 2012-11-14

Re: [PATCH 2/3] spi / ACPI: add ACPI enumeration support

From: Rafael J. Wysocki <hidden>
Date: 2012-11-07 11:10:22
Also in: lkml

On Wednesday, November 07, 2012 11:58:42 AM Mika Westerberg wrote:
On Tue, Nov 06, 2012 at 11:36:08PM +0100, Rafael J. Wysocki wrote:
quoted
quoted
OK, but then we need to pass the information obtained from _CRS
(presumably after some adjustments through _SRS) to drivers, or rather to
things like the SPI core, I2C core etc. so that they can create device
objects for drivers to bind to and quite frankly I don't see why not to use
ACPI resources for that.
Nevertheless, the routines for parsing those resources should belong
to the ACPI core, mostly to avoid code duplication.
Rafael,

So is the idea now that the ACPI core parses the resources and passes them
forward via struct acpi_device? I'm just wondering how to proceed with
these I2C and SPI enumeration patches.
Well, we definitely don't want to duplicate what drivers/pnp/pnpacpi/rsparser.c
does, so the idea is to move the code from there to the core in such a way that
both the SPI/I2C patches and the PNP layer can use it.

I'll have some prototype code ready shortly, hopefully, and I'll post it
in that form for comments (and so that you know what to expect).

Thanks,
Rafael


-- 
I speak only for myself.
Rafael J. Wysocki, Intel Open Source Technology Center.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help