Thread (1 message) 1 message, 1 author, 2005-01-11

Re: S3 resume in 2.6.10 on Dell D600 with black screen

From: Jing Su <hidden>
Date: 2005-01-11 21:07:33

  But with kernel 2.6.10 after resume from S3 I have black screen. The
same result with radeonfb or with vga only (tested without X).
I have been experiencing the same problems with kernel 2.6.9 as well. 
The system works perfectly after suspend to disk (S4).  But with S3, I
get the blank screen with and without X.  I'm running Fedora 3, in an
Acer with an integrated Intel display adapter.

After resume from S3, the rest of the system comes up fine; I can even
SSH into the machine.  However, the display adapter does not come back
up.  The screen stays blank, with the backlight off.  I've tried
toggling the LCD/VGA display switch hotkey, to no avail.  Also, I've
brought the machine out of S3 in console, and then attempted to start
X.  X fails to start.  /var/log/messages shows the system going into
S3, and then coming out.  There are no error messages reported about
failure to re-start the video adapter.

I'm a competent programmer, though I have no experience with Kernel or
ACPI development.  If someone can give me some hints/pointers, I think
I can try to help out with this issue.


-------------------------------------------------------
The SF.Net email is sponsored by: Beat the post-holiday blues
Get a FREE limited edition SourceForge.net t-shirt from ThinkGeek.
It's fun and FREE -- well, almost....http://www.thinkgeek.com/sfshirt
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help