Thread (51 messages) 51 messages, 6 authors, 2021-12-17

Re: [PATCH v3 03/18] driver core: platform: Rename platform_dma_configure()

From: Dan Williams <hidden>
Date: 2021-12-07 23:09:44
Also in: linux-iommu, linux-pci, lkml

On Mon, Dec 6, 2021 at 7:04 AM Jason Gunthorpe [off-list ref] wrote:
On Mon, Dec 06, 2021 at 06:47:45AM -0800, Christoph Hellwig wrote:
quoted
On Mon, Dec 06, 2021 at 10:45:35AM -0400, Jason Gunthorpe via iommu wrote:
quoted
IIRC the only thing this function does is touch ACPI and OF stuff?
Isn't that firmware?

AFAICT amba uses this because AMBA devices might be linked to DT
descriptions?
But DT descriptions aren't firmware.  They are usually either passed onb
the bootloader or in some deeply embedded setups embedded into the
kernel image.
Pedenatically yes, but do you know of a common word to refer to both
OF and ACPI that is better than firmware? :)

AFAICT we already use firwmare for this in a few places, eg
fwnode_handle and so on.
I've always thought 'platform' was the generic name for otherwise
non-enumerable platform-firmware/data things enumerated by ACPI / OF.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help