On Thu, Jul 15, 2021 at 06:58:31PM +0530, Kirti Wankhede wrote:
quoted
Review of all the drivers show that they are either already open coding
the first/last semantic or are buggy and missing it. All drivers are
migrated/fixed to the new open/close_device ops and the unused per-FD
open()/release() ops are deleted.
Why can't open()/release() ops be reused instead of adding
open_device()/close_device().
It could be done but it would ruin the structure of the patch series,
obfuscate the naming of the ops, and complicate backporting as this is
a significant semantic difference.
Overall when funtionality changes significantly it is better to change
the name along with it
Jason