Re: [RFC] /dev/ioasid uAPI proposal
From: Jason Gunthorpe <jgg@nvidia.com>
Date: 2021-06-15 15:06:36
Also in:
linux-iommu, lkml
On Tue, Jun 15, 2021 at 08:59:25AM +0000, Tian, Kevin wrote:
Hi, Jason,quoted
From: Jason Gunthorpe Sent: Thursday, June 3, 2021 9:05 PM On Thu, Jun 03, 2021 at 06:39:30AM +0000, Tian, Kevin wrote:quoted
quoted
quoted
Two helper functions are provided to support VFIO_ATTACH_IOASID: struct attach_info { u32 ioasid; // If valid, the PASID to be used physically u32 pasid; }; int ioasid_device_attach(struct ioasid_dev *dev, struct attach_info info); int ioasid_device_detach(struct ioasid_dev *dev, u32 ioasid);Honestly, I still prefer this to be highly explicit as this is where all device driver authors get invovled: ioasid_pci_device_attach(struct pci_device *pdev, struct ioasid_dev *dev, u32 ioasid); ioasid_pci_device_pasid_attach(struct pci_device *pdev, u32*physical_pasid,quoted
quoted
struct ioasid_dev *dev, u32 ioasid);Then better naming it as pci_device_attach_ioasid since the 1st parameter is struct pci_device?No, the leading tag indicates the API's primary subystem, in this case it is iommu (and if you prefer list the iommu related arguments first)I have a question on this suggestion when working on v2. Within IOMMU fd it uses only the generic struct device pointer, which is already saved in struct ioasid_dev at device bind time: struct ioasid_dev *ioasid_register_device(struct ioasid_ctx *ctx, struct device *device, u64 device_label); What does this additional struct pci_device bring when it's specified in the attach call? If we save it in attach_data, at which point will it be used or checked?
The above was for attaching to an ioasid not the register path You should call 'device_label' 'device_cookie' if it is a user provided u64 Jason