On Thu, 05 Jul 2012 09:02:23 +0200, Sasha Levin [off-list ref] wrote:
On Thu, 2012-07-05 at 08:47 +0200, Paolo Bonzini wrote:
quoted
Il 04/07/2012 23:11, Sasha Levin ha scritto:
quoted
There are two things going on here:
1. Rename VIRTIO_BLK_F_FLUSH to VIRTIO_BLK_F_WCE
2. Add a new VIRTIO_BLK_F_CONFIG_WCE
I'm concerned that the first change is going to break compilation for
any code that included linux/virtio-blk.h and used VIRTIO_BLK_F_FLUSH.
That would be nlkt, right? :)
nlkt, lguest, and probably others.
linux/virtio_blk.h is a public kernel header, which is supposed to be
used from userspace - so I assume many others who implemented virtio-blk
for any reason took advantage of that header.
lguest doesn't have an API, so it can be patched.
But if someone else breaks, then yes, we need to define the old name
too.
Cheers,
Rusty.