Thread (7 messages) 7 messages, 3 authors, 2021-12-14

Re: [PATCH 1/3] scsi: hisi_sas: Use devm_bitmap_zalloc() when applicable

From: "Martin K. Petersen" <martin.petersen@oracle.com>
Date: 2021-12-14 04:41:14
Also in: linux-scsi, lkml

On Fri, 26 Nov 2021 22:15:21 +0100, Christophe JAILLET wrote:
'hisi_hba->slot_index_tags' is a bitmap. So use 'devm_bitmap_zalloc()' to
simplify code, improve the semantic and avoid some open-coded arithmetic
in allocator arguments.
Applied to 5.17/scsi-queue, thanks!

[1/3] scsi: hisi_sas: Use devm_bitmap_zalloc() when applicable
      https://git.kernel.org/mkp/scsi/c/54585ec62fbd
[2/3] scsi: hisi_sas: Remove some useless code in 'hisi_sas_alloc()'
      https://git.kernel.org/mkp/scsi/c/d43efddf6271
[3/3] scsi: hisi_sas: Use non-atomic bitmap functions when possible
      https://git.kernel.org/mkp/scsi/c/4d6942e2666e

-- 
Martin K. Petersen	Oracle Linux Engineering
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help