Thread (75 messages) 75 messages, 6 authors, 9d ago

Re: [PATCH v3 0/9] odb: introduce object filters to `odb_for_each_object()`

From: Patrick Steinhardt <hidden>
Date: 2026-07-15 06:22:05

On Wed, Jul 15, 2026 at 07:43:56AM +0200, Toon Claes wrote:
Patrick Steinhardt [off-list ref] writes:
quoted
On Mon, Jul 13, 2026 at 08:59:39PM -0700, Taylor Blau wrote:
quoted
On Mon, Jul 13, 2026 at 04:41:24PM +0200, Patrick Steinhardt wrote:
quoted
Range-diff versus v2:

 1:  baf2adb012 =  1:  7c0dc1be0d odb/source-packed: improve lookup when enumerating objects
 2:  57eecf3031 =  2:  2e5908c9c3 pack-bitmap: mark object filter as `const`
 -:  ---------- >  3:  f4d66ccfc6 pack-objects: drop unused return value from add_object_entry()
 3:  92dd6a6f6e =  4:  af475654b8 pack-bitmap: allow aborting iteration of bitmapped objects
 4:  92fe41577d =  5:  6ca42587c9 pack-bitmap: iterate object sources when opening bitmaps
 5:  e5d59959e3 =  6:  f62c3bbc81 pack-bitmap: drop `_1` suffix from functions that open bitmaps
 6:  ab3547ac2b =  7:  b2d25b6e9b pack-bitmap: introduce function to open bitmap for a single source
 7:  026f21f522 =  8:  a5bf309bec odb: introduce object filters to `odb_for_each_object()`
 8:  534b25c817 =  9:  600b15a907 builtin/cat-file: filter objects via object database
Thanks, this version looks good to me.
I only posted a nit about function name in the commit messages 7 & 8
isn't correct, but other than that I'm happy with these patches too.
Thanks for your review! I'll send one more iteration that fixes these
nits.

Patrick
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help