Re: [PATCH v2 00/11] receive-pack: use ODB transactions to stage object writes
From: Justin Tobler <hidden>
Date: 2026-07-08 17:36:50
On 26/07/08 08:42AM, Patrick Steinhardt wrote:
On Tue, Jul 07, 2026 at 11:14:01PM -0500, Justin Tobler wrote:quoted
Changes since V1: - Adapted other "file" ODB transaction helpers to be more consistent with current naming scheme. - Removed redundant NULL transaction handling from `odb_transaction_files_begin()`. - `odb_transaction_begin()` now returns an error if there is already an inflight transaction pending instead of setting the `out` pointer to NULL. - Updated `odb_transaction_env()` to return an error code and append environment variables to a strvec provided as an argument. - Removed redundant setting of tmpdir environment variables for child processes after tmpdir has been migrated. - Split changes adding ODB transaction flags into a separate commit. - Consistently wire the ODB transaction throughout git-receive-pack code instead of reading it from `the_repository`. - Updated user facing error message. - Updated some comments to better document functions/flags. - Clarified some commit messages. - Fixed typos.I've got a couple smaller nits, but overall I'm quite happy with the shape of this series now. Thanks!
Thanks for the review! I'll send another version later today. :) -Justin