Thread (29 messages) 29 messages, 10 authors, 1d ago

Re: [PATCH RFC v2 2/2] Move libgit.a sources into separate "lib/" directory

From: Kaartic Sivaraam <hidden>
Date: 2026-07-06 04:29:26

On 02/07/26 10:51, Patrick Steinhardt wrote:
On Wed, Jul 01, 2026 at 07:45:09AM -0700, Junio C Hamano wrote:
quoted
Phillip Wood [off-list ref] writes:
quoted
Another cost is remembering things have moved - the other day I spent
too long wondering why "git show origin/seen:wt-status.c" wasn't working
until I ran "git log origin/seen" and realized it had move to
lib/wt-status.c.
Yes, this has bit me multiple dozen times, as the tip of 'seen' is
contaminated with this rename, already.  It is a huge pain.
Yeah, this one I don't have any arguments against besides a very
hand-wavy "it'll get better over time" :)
On a bit of a tangent, this made me wonder if it would be helpful to 
make a potential improvement to 'git show' UX that shows a hint that the 
file asked to be shown was moved as part of a recent rename.

Something like:

   $ git show origin/seen:wt-status.c
   fatal: path 'wt-status.c' does not exist in 'origin/seen'
   hint: 'wt-status.c' appears to have been renamed to 
'builtin/wt-status.c' in 'origin/seen'
   hint: Did you mean 'origin/seen:builtin/wt-status.c'?
   hint: Disable this message with "git config advice.objectNameWarning 
false"

Finding rename just to show a hint sounds a bit too much work for a 
hint. I wonder if it would worth given the better UX, though.

--
Sivaraam
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help