Re: [PATCH v2 3/9] reset: modernize flags passed to `reset_head()`
From: Patrick Steinhardt <hidden>
Date: 2026-06-08 09:14:27
From: Patrick Steinhardt <hidden>
Date: 2026-06-08 09:14:27
On Fri, Jun 05, 2026 at 04:08:57PM +0100, Phillip Wood wrote:
Hi Patrick On 03/06/2026 17:14, Patrick Steinhardt wrote:quoted
-/* Update ORIG_HEAD as well as HEAD */ -#define RESET_ORIG_HEAD (1<<4) [...]> + /* Update ORIG_HEAD as well as HEAD */ + RESET_HEAD_ORIG_HEAD = (1 << 4),I'm having a hard time parsing this new name, if we must have a "RESET_HEAD_" prefix can we call it something like RESET_HEAD_UPDATE_ORIG_HEAD?
Yeah, that reads better indeed. Amended locally, thanks! Patrick