Re: [PATCH v5 1/2] config: let git_config_parse_key() validate quietly
From: Harald Nordgren <hidden>
Date: 2026-06-02 16:32:14
From: Harald Nordgren <hidden>
Date: 2026-06-02 16:32:14
Perhaps the updated "git_config_parse_key()" in this patch should be renamed to be a file-scape static internal helper, and the existing "git_config_parse_key()" should become a thin wrapper around that new helper function, retaining the current external interface, requiring no changes to existing callers.
I want to remember a discussion on one of my earlier topics, a few months back, where someone else suggested instead of introducing two thin wrappers over a helper, we should update the callers instead. But for me either way is fine, maybe here it makes more sense, because of the repeated NULL/0/1 parameters. Harald