Patrick Steinhardt [off-list ref] writes:
Currently, all state that relates to loose objects is held directly by
the `struct odb_source`. Introduce a new `struct odb_loose_source` to
hold the state instead so that it is entirely self-contained.
I wonder if the naming should instead be `struct obd_source_loose` that
way other backends (if added) would be something like:
struct obd_source_loose
struct obd_source_postgres
struct obd_source_mongo
This is easier to read and also for autocompletion it leads nicely into
the 'obd_source_...' namespace.
The patch looks good.
[snip]