Re: [PATCH] CodingGuidelines: discourage arbitrary suffixes in function names
From: Taylor Blau <hidden>
Date: 2024-10-24 16:50:07
From: Taylor Blau <hidden>
Date: 2024-10-24 16:50:07
On Wed, Oct 23, 2024 at 05:50:17PM -0700, Junio C Hamano wrote:
Surely all of _1(), _helper(), _recursive() are meaningless. If we were to replace existing uses of them, the replacement has to be 10x better.
Well put. Each of the three are more or less equally meaningless, but _1() is an accepted (?) project convention and has the fewest characters, so I think is a good choice personally.
Having said all that, as an aspirational goal, I think it is good to encourage people to find a name that is descriptive when writing a new function. I'd refrain from judging if it is way too obvious to be worth documenting (as I am officially on vacation and shouldn't be thinking too much about the project).
Yeah, go back to vacation ;-). Thanks, Taylor