Phillip Wood [off-list ref] writes:
Thanks for re-rolling, I think "Fix some compiler warnings" would be
clearer than "Remove", also "integers" is misspelt.
Though "Fix" is a word with less information than other words we
could use. The changes in the patch are primarily about mismatched
type, so perhaps
mingw: use size_t insead of int for lengths
would make a better commit title.
I agree with everything you said including this part:
It would also be helpful to explain in the commit message the changes
to _ssize_t
quoted
+#ifdef _WIN64
+typedef __int64 _ssize_t;
+#else
typedef long _ssize_t;
+#endif // _AMD64
Please note that we do not use "//" comments so this should be "/*
_WIN64 */" so that the comment matches the opening #ifdef
Thanks for working on this
Thanks.