Thread (2 messages) 2 messages, 2 authors, 2024-10-09

Re: [PATCH v5 2/6] set-head: add new variable for readability

From: Bence Ferdinandy <hidden>
Date: 2024-10-09 19:53:09

On Wed Oct 09, 2024 at 21:26, Junio C Hamano [off-list ref] wrote:
Bence Ferdinandy [off-list ref] writes:
quoted
Instead of calling get_main_ref_store(the_repository) multiple times,
call it once and store in a new refs variable. Although this change
probably offers some performance benefits, the main purpose is to
shorten the line lengths of function calls using this variable for
better readability.
---

Notes:
    v5: new patch (split from the next patch as a preparatory step)
It is a good idea to help making it obvious that we are accessing
the same ref store.
Indeed, although it was your idea ;)
The patch needs to be signed-off, though.
Damn :/ Sorry, another oversight ... Should I send a v6 for the series with
this fixed now or wait a bit to see if there are other comments?

Thanks again for the patience!

Best,
Bence
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help