Patrick Steinhardt [off-list ref] writes:
quoted
Yes, if the function is about obtaining the path for a file in a
given repository's metadata directory, and its association with
"strbuf" is that it merely happens to use it instead of "char *",
it should not be named as if "strbuf_" ness is the primary
characteristics of the function.
strbuf_cleanup_path() should also be renamed for the same reason.
Agreed. I was doing it for consistency's sake in this case, but let's
rather not make the overall interface any weirder than it already is.
Thanks, then we are in agreement.